Investigating - Unstable servers this morning.
Incident Report for Runrun.it
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 22, 2017 - 12:11 GMT-02:00
Investigating
Technical team investigating.
Posted almost 2 years ago. Nov 22, 2017 - 11:39 GMT-02:00