Degraded Performance
Incident Report for Runrun.it
Resolved
This incident has been resolved.
Posted almost 5 years ago. Oct 30, 2014 - 21:52 GMT-02:00
Investigating
We are currently investigating this issue.
Posted almost 5 years ago. Oct 30, 2014 - 15:45 GMT-02:00