Degraded performance
Incident Report for Runrun.it
Resolved
Performance issues resolved. There might have been some emails not sent and reports not generated during the period.
Posted over 4 years ago. Mar 25, 2015 - 10:42 GMT-03:00
Investigating
We are experiencing performance problems that are under investigation at this moment.
Posted over 4 years ago. Mar 25, 2015 - 10:16 GMT-03:00